Michael H. Schimek wrote:
struct v4l2_cropcap {
__u32 bounds_left;
__u32 bounds_top;
__u32 bounds_width;
__u32 bounds_height;
__u32 default_left;
__u32 default_top;
__u32 default_width;
__u32 default_height;
struct {
__u32 numerator;
__u32 denominator;
} pixel_aspect;
}
Not to nitpick, but wouldn't this be a bit simpler:
struct v4l2_cropcap {
struct v4l2_coords bounds;
struct v4l2_coords default;
struct {
__u32 numerator;
__u32 denominator;
} pixel_aspect;
}
and then rename v4l2_crop to v4l2_coords (or v4l2_rectangle or
whatever). The same struct could be used in v4l2_clip and v4l2_window as
well. IMHO that would make coding a bit easier, since you could pass
pointers to these structs around internally, write a generic
copy_coords() inline function, etc...
Either way, I like this API much better than v4l2_zoom. Nice job!
--
Mark McClelland
mark@xxxxxxxxxxxxxxxx